GetSubface Method


Returns a face that represents the portion of the room face bounded by the boundary element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public Face GetSubface()
Visual Basic
Public Function GetSubface As Face
Visual C++
public:
Face^ GetSubface()

Return Value

The sub-face.

Remarks

If the spatial element's face is adjacent to multiple bounding elements (such as two different walls), there will be one sub-face for each portion of the spatial element's face where it is adjacent to one of those room-bounding elements. This is equivalent to the return of GetRoomFace() if the entire room face is created by the boundary element.

See Also