The family parameter label of the dimension.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
A dimension only can be labeled to a family parameter in a family document. When the dimension is labeled by a reporting parameter, the dimension value drives the parameter value. When the parameter is labeled by a non-reporting, the value of the parameter drives the dimension. If the dimension is multi-segmented, each segment of the dimension is driven by the same parameter value. Multi-segmented dimensions cannot be labeled by reporting parameters. To unbind the family parameter, set this property to a null reference ( Nothing in Visual Basic) .
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when the family parameter's ParameterType is not suitable for this dimension. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when dimension can not be labeled. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when failed to get the BuiltInParameter DIM_LABEL. |