GetHostIds Method


Gets a list of all host walls on which the sweep resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public IList<ElementId> GetHostIds()
Visual Basic
Public Function GetHostIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetHostIds()

Return Value

The list of wall ids.

Remarks

Fixed wall sweeps from vertically compound structures will return only one host element.

See Also