GetRuleParameters Method


Retrieves a list of the parameters associated with each rule in the filter. The order of the resulting array corresponds to the order in which the associated filter rules are applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public IList<ElementId> GetRuleParameters()
Visual Basic
Public Function GetRuleParameters As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetRuleParameters()

Return Value

An array of parameter identifiers.

See Also