IsRational Property


Tells if the spline is rational or not. If it is true (rational), then the NURBS is a piecewise rational polynomial function. If it is false (non-rational), then the NURBS is a piecewise polynomial function.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2016

Syntax

C#
public bool IsRational { get; }
Visual Basic
Public ReadOnly Property IsRational As Boolean
	Get
Visual C++
public:
property bool IsRational {
	bool get ();
}

See Also