ReferencePoint Property


The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2013

Syntax

C#
public XYZ ReferencePoint { get; set; }
Visual Basic
Public Property ReferencePoint As XYZ
	Get
	Set
Visual C++
public:
property XYZ^ ReferencePoint {
	XYZ^ get ();
	void set (XYZ^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also