BarTypeDoesNotAllowHooksOfCurrentShape Property


You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public static FailureDefinitionId BarTypeDoesNotAllowHooksOfCurrentShape { get; }
Visual Basic
Public Shared ReadOnly Property BarTypeDoesNotAllowHooksOfCurrentShape As FailureDefinitionId
	Get
Visual C++
public:
static property FailureDefinitionId^ BarTypeDoesNotAllowHooksOfCurrentShape {
	FailureDefinitionId^ get ();
}

See Also