RestoreImageSize Method


Restores all images to their original sizes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public void RestoreImageSize()
Visual Basic
Public Sub RestoreImageSize
Visual C++
public:
void RestoreImageSize()

Remarks

All images in the schedule will be restored to their original sizes when viewed as a ScheduleSheetInstance on a ViewSheet. This reverts any changes made by setting ImageRowHeight . Calling this method has no effect if HasImageField is false.

In the schedule view the column widths will be adjusted to match the image sizes, but only the name of the image will be shown. For example, the users can attach different images to the kinds of rebar instances. These images may have different sizes. When the users create the rebar schedule with this image field, by default the column width of this image field is equal to other fields, which means it is not associated with the image original sizes during the schedule creation.

See Also