RampRunTooComplex Property


Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public static FailureDefinitionId RampRunTooComplex { get; }
Visual Basic
Public Shared ReadOnly Property RampRunTooComplex As FailureDefinitionId
	Get
Visual C++
public:
static property FailureDefinitionId^ RampRunTooComplex {
	FailureDefinitionId^ get ();
}

See Also