GetSketchCurves Method


Returns copies of the Curves that form this RevisionCloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public IList<Curve> GetSketchCurves()
Visual Basic
Public Function GetSketchCurves As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetSketchCurves()

Return Value

Copies of the sketched curves that form this RevisionCloud.

Remarks

Note that there is no requirement that the curves form closed loops or avoid self-intersections. The curves may also form multiple closed loops.

See Also