GetFirstProfileCurve Method


Returns a copy of the first profile curve if it is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2017

Syntax

C#
public Curve GetFirstProfileCurve()
Visual Basic
Public Function GetFirstProfileCurve As Curve
Visual C++
public:
Curve^ GetFirstProfileCurve()

Return Value

A copy of the first profile curve, if it exists. If a point was used to define the first profile, this function will return a null reference ( Nothing in Visual Basic) .

See Also