Material Property


Retrieves or changes the material of the category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public Material Material { get; set; }
Visual Basic
Public Property Material As Material
	Get
	Set
Visual C++
public:
property Material^ Material {
	Material^ get ();
	void set (Material^ value);
}

Field Value

a null reference ( Nothing in Visual Basic) if this category does not have a material.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException When setting this property: material cannot be set for annotation categories.

See Also