This base class represents an external service inside Revit application.
Namespace:
Autodesk.Revit.DB.ExternalService
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
This is a base class from which SingleServerService and MultiServerService classes are inherited. It implements all basic methods, but the two inherited classes add more methods specific for that kind of service the class represents. Use this base class to get information about a service and its servers. Use the specific inherited classes to set or get active servers.
Summary of common methods:- Adding and removing a server to and from a service
- Getting information about a service
- Querying a number of servers registered for a service
- Accessing servers currently registered for a service
- Getting and setting active server (or servers) for a service
Inheritance Hierarchy
System
Object
Autodesk.Revit.DB.ExternalService ExternalService
Autodesk.Revit.DB.ExternalService MultiServerService
Autodesk.Revit.DB.ExternalService SingleServerService
Autodesk.Revit.DB.ExternalService ExternalService
Autodesk.Revit.DB.ExternalService MultiServerService
Autodesk.Revit.DB.ExternalService SingleServerService