SubmitPrint Method


Print the views and sheets defined in the current local PrintManager settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public bool SubmitPrint()
Visual Basic
Public Function SubmitPrint As Boolean
Visual C++
public:
bool SubmitPrint()

Return Value

True if successful, otherwise False.

Remarks

PrintManager will apply the local settings to global and print the view/views/sheets which user defined with the current settings.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also