GetSimilarTypes Method


Obtains a set of types that are similar to this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public ICollection<ElementId> GetSimilarTypes()
Visual Basic
Public Function GetSimilarTypes As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetSimilarTypes()

Return Value

A set of element IDs of types that are similar to this type.

Remarks

Two types are similar if elements that have one type could be assigned the other type.

See Also