GetGeometryObject Method


Retrieve one geometric primitive representing given subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public GeometryObject GetGeometryObject()
Visual Basic
Public Function GetGeometryObject As GeometryObject
Visual C++
public:
GeometryObject^ GetGeometryObject()

Return Value

The geometric object representing this subelement.

Remarks

In case of whole element, geometric object representing element and its subelements will be returned. a null reference ( Nothing in Visual Basic) will be returned if related geometric object could not be found in the model.

See Also