Curve Class


A parametric curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class Curve : GeometryObject
Visual Basic
Public Class Curve _
	Inherits GeometryObject
Visual C++
public ref class Curve : public GeometryObject

Remarks

The concrete curves are defined by parametric equations. If the curve is bound, it is only defined for an interval in parameterization. Otherwise, it is defined for all values of the parameter.

Inheritance Hierarchy

See Also