StructuralWallUsageFilter Class


A filter used to match walls that have the given structural wall usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public class StructuralWallUsageFilter : ElementSlowFilter
Visual Basic
Public Class StructuralWallUsageFilter _
	Inherits ElementSlowFilter
Visual C++
public ref class StructuralWallUsageFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

See Also