GetAbsolutePath Method


Returns an absolute path to the referenced file, regardless of whether the PathType.Enum is relative or absolute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public ModelPath GetAbsolutePath()
Visual Basic
Public Function GetAbsolutePath As ModelPath
Visual C++
public:
ModelPath^ GetAbsolutePath()

Return Value

A full path to the linked model.

Remarks

ExternalFileReferences which are taken from a closed document will report their absolute path as of the last time the document was saved.

See Also