MessageBoxData Class


An object that represents a simple message box that prompts the user for some action.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class MessageBoxData : DialogBoxData
Visual Basic
Public Class MessageBoxData _
	Inherits DialogBoxData
Visual C++
public ref class MessageBoxData : public DialogBoxData

Remarks

When the application receives this object, a simple message box is displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

See Also