Constructs a new instance of a RebarConstraintProjectEdgedLength object using a shape
parameter, direction, and reference types.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- paramId
-
Type:
Autodesk.Revit.DB
ElementId
The Id of a Rebar Shape parameter.
- direction
-
Type:
Autodesk.Revit.DB
UV
A vector specifying the direction of the constraint. The direction is fixed, and the shape is always constructed so that the segment's direction has a positive dot product with this vector.
- tripleProductSign
-
Type:
System
Int32
Sign of the z-coordinate of the cross product of the "direction" argument with the segment vector. In other words, 1 if the segment direction is to be on the left of the constraint direction, or -1 if the segment direction is to be on the right.
- refType0
-
Type:
Autodesk.Revit.DB.Structure
RebarShapeSegmentEndReferenceType
Choose between two possibilities for the first reference of the length constraint.
- refType1
-
Type:
Autodesk.Revit.DB.Structure
RebarShapeSegmentEndReferenceType
Choose between two possibilities for the second reference of the length constraint.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | paramId is not a valid Element identifier. -or- tripleProductSign is not 1 or -1. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | direction has zero length. -or- A value passed for an enumeration argument is not a member of that enumeration |