GetAssociatedFamilyParameter Method


Gets the associated family parameter of an element parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public FamilyParameter GetAssociatedFamilyParameter(
	Parameter elementParameter
)
Visual Basic
Public Function GetAssociatedFamilyParameter ( _
	elementParameter As Parameter _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ GetAssociatedFamilyParameter(
	Parameter^ elementParameter
)

Parameters

elementParameter
Type: Autodesk.Revit.DB Parameter
The parameter of an element in family.

Return Value

The associated family parameter if there is an association between them, returns a null reference ( Nothing in Visual Basic) if not.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when the input argument-"elementParameter"-is a null reference ( Nothing in Visual Basic) .

See Also