NewReferencePoint Method (PointElementReference)


Create a reference point on an existing reference in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public ReferencePoint NewReferencePoint(
	PointElementReference A_0
)
Visual Basic
Public Function NewReferencePoint ( _
	A_0 As PointElementReference _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
	PointElementReference^ A_0
)

Return Value

The newly created ReferencePoint.

Remarks

The location and coordinate system of the point is determined by the particular PointReference subclass, and the point will remain constrained to that reference.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when the argument is a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions InvalidOperationException Thrown when the family is not a Conceptual Mass Family.

See Also