SharedParameterElement Class


An element that stores the definition of a shared parameter which is loaded into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public class SharedParameterElement : ParameterElement
Visual Basic
Public Class SharedParameterElement _
	Inherits ParameterElement
Visual C++
public ref class SharedParameterElement : public ParameterElement

Remarks

Shared parameters are user-defined parameters that can be shared by multiple Revit documents. A shared parameter is identified by a GUID. Basic information of the shared parameter are accessed through GetDefinition().

Inheritance Hierarchy

See Also