Specifies kind of analytical model loop.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2013
Since:
2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
All | All analytical loops of analytical model surface elements (floor, slab, wall). |
External | Loops outside all other loops. In case of multiple nested loops, this will return the most external loop. |
Internal | An internal loop is a loop that is inside another loop. In the case of multiple nested loops, this will return all loops except the most external loop. |
Filled | Loops that are filled inside. In the case of multiple nested loops, this will return the most external and every second loop going from external to internal. In the view, returned loops are presented as external outline of solids. |
Void | Loops that are empty inside. In the case of multiple nested loops, this will return a series of loops starting from second most external and every second heading into the most internal. In the view returned loops are presented as external outline of openings. |