Creates a floor within the project with the given horizontal profile and floor style on the specified level.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- profile
- Type: Autodesk.Revit.DB CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
- floorType
- Type: Autodesk.Revit.DB FloorType
A floor type to be used by the new floor instead of the default type.
- level
- Type: Autodesk.Revit.DB Level
The level on which the floor is to be placed.
- structural
- Type: System Boolean
If set, specifies that the floor is structural in nature.
Return Value
if successful, a new floor object within the project, otherwise a null reference ( Nothing in Visual Basic) .Remarks
The curves of the profile must be contiguous and the Face formed by profile should be suitable to create floor.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if the floor type does not exist in the given document. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the level does not exist in the given document. |