Get the ElementId of the MassSurfaceData corresponding to the Reference.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- reference
- Type: Autodesk.Revit.DB Reference
A Reference to a face of this MassEnergyAnalyticalModel.
Return Value
ElementId of a MassSurfaceData.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The Reference is not a Face of this MassEnergyAnalyticalModel. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |