IsValidAnalyticalProjectionType Method


Indicates whether Analytical Projection Type is valid for Sketch Component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public bool IsValidAnalyticalProjectionType(
	AnalyticalProjectionType projectionType
)
Visual Basic
Public Function IsValidAnalyticalProjectionType ( _
	projectionType As AnalyticalProjectionType _
) As Boolean
Visual C++
public:
bool IsValidAnalyticalProjectionType(
	AnalyticalProjectionType projectionType
)

Parameters

projectionType
Type: Autodesk.Revit.DB.Structure AnalyticalProjectionType
Analytical Projection Type preset to test for validity.

Return Value

True is projection type is valid, false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also