SetCellCalculatedValue Method (Int32, TableCellCalculatedValueData)


Allows the caller to set the calculated value for a specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public void SetCellCalculatedValue(
	int nCol,
	TableCellCalculatedValueData pCalcValue
)
Visual Basic
Public Sub SetCellCalculatedValue ( _
	nCol As Integer, _
	pCalcValue As TableCellCalculatedValueData _
)
Visual C++
public:
void SetCellCalculatedValue(
	int nCol, 
	TableCellCalculatedValueData^ pCalcValue
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The given column number nCol is invalid.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException This operation is forbidden for cells in standard schedule header sections. -or- This operation is forbidden for cells in standard schedule body sections.

See Also