SetAnalyticalProjectionDatumPlane Method


Sets the Analytical Projection to supplied Datum Plane.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public void SetAnalyticalProjectionDatumPlane(
	ElementId datumPlaneId
)
Visual Basic
Public Sub SetAnalyticalProjectionDatumPlane ( _
	datumPlaneId As ElementId _
)
Visual C++
public:
void SetAnalyticalProjectionDatumPlane(
	ElementId^ datumPlaneId
)

Parameters

datumPlaneId
Type: Autodesk.Revit.DB ElementId
Identifies Datum Plane ElementId.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException datumPlaneId is not valid for this Sketch Component.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also