ViewExporting Event


Subscribe to the ViewExporting event to be notified when Revit is just about to export a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public event EventHandler<ViewExportingEventArgs> ViewExporting
Visual Basic
Public Event ViewExporting As EventHandler(Of ViewExportingEventArgs)
Visual C++
public:
 event EventHandler<ViewExportingEventArgs^>^ ViewExporting {
	void add (EventHandler<ViewExportingEventArgs^>^ value);
	void remove (EventHandler<ViewExportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to export a view of the document. It is raised only during accelerated export jobs, in which views are exported in parallel using a background process. Accelerated export only occurs when exporting to DWF formats and not combining views into a single file.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event's argument is always False.

The following API functions are not available for the current document during this event:

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewExported will be raised immediately after view exporting is finished.

See Also