Return the parameter's formula, if one is associated with it.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2009
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- paramId
- Type: Autodesk.Revit.DB ElementId
Id of a parameter in the definition.
Return Value
The formula, or an empty string if there is no formula for the parameter.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This RebarShapeDefinition does not have a value for the parameter paramId. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |