The ID of the field to calculate percentages of.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
The ID of the field, or InvalidElementId.Remarks
A Percentage field calculates what percent of the total of another field each element represents. PercentageOf is the ID of the field used to calculate percentages. If PercentageOf is InvalidScheduleFieldId, no data is displayed.
Percentages can only be calculated for numeric fields. The Count field and other percentage fields cannot be used to calculate percentages.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | When setting this property: percentageOf is not InvalidScheduleFieldId or the ID of a field that can be used to calculated percentages. -or- When setting this property: percentageOf would create a circular chain of references. |
Autodesk.Revit.Exceptions ArgumentNullException | When setting this property: A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | When setting this property: This ScheduleField is not a percentage field. |