ExportToMAJ Method


Exports a list of fabrication parts into the native fabrication job (MAJ) format.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2018.1

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. Use 'FabricationPart.SaveAsFabricationJob()' instead.")]
public static int ExportToMAJ(
	Document document,
	IList<ElementId> ids,
	string filename,
	bool addHolesForTaps,
	out IList<ElementId> idsNotExported
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. Use 'FabricationPart.SaveAsFabricationJob()' instead.")> _
Public Shared Function ExportToMAJ ( _
	document As Document, _
	ids As IList(Of ElementId), _
	filename As String, _
	addHolesForTaps As Boolean, _
	<OutAttribute> ByRef idsNotExported As IList(Of ElementId) _
) As Integer
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2019 and will be removed in the next version of Revit. Use 'FabricationPart.SaveAsFabricationJob()' instead.")]
public:
static int ExportToMAJ(
	Document^ document, 
	IList<ElementId^>^ ids, 
	String^ filename, 
	bool addHolesForTaps, 
	[OutAttribute] IList<ElementId^>^% idsNotExported
)

Parameters

document
Type: Autodesk.Revit.DB Document
The document.
ids
Type: System.Collections.Generic IList ElementId
An array of FabricationPart element identifiers. Non-fabrication parts are ignored.
filename
Type: System String
The name given to the output file.
addHolesForTaps
Type: System Boolean
Set true to have holes for taps on straights added to the created fabrication job.
idsNotExported
Type: System.Collections.Generic IList ElementId %
An array of element identifiers that were not included in the export.

Return Value

Returns the number of fabrication parts created in the export. Returns zero if no valid fabrication parts or unable to create the file.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException Fabrication configuration is missing.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also