Returns ChangeType associated with a change in a parameter's value
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- param
- Type: Autodesk.Revit.DB Parameter
Parameter for the ChangeType to trigger on
Return Value
ChangeType that can be used to define a trigger for an Updater, triggering on parameter value changeRemarks
Use this change type to trigger an Updater when the value of an element's parameter changes. Note: This change type will not trigger on newly created or deleted elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was a null reference ( Nothing in Visual Basic) |