GetRules Method


Returns the rules of this filter, in the order in which they are applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you instead use GetElementFilter instead.")]
public IList<FilterRule> GetRules()
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you instead use GetElementFilter instead.")> _
Public Function GetRules As IList(Of FilterRule)
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you instead use GetElementFilter instead.")]
public:
IList<FilterRule^>^ GetRules()

Remarks

This function should only be called if usesConjunctionOfFilterRules returns 'true'.

See Also