StructuralMaterialTypeFilter Constructor (StructuralMaterialType)


Constructs a new instance of a filter to match family instances that have the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public StructuralMaterialTypeFilter(
	StructuralMaterialType structuralMaterialType
)
Visual Basic
Public Sub New ( _
	structuralMaterialType As StructuralMaterialType _
)
Visual C++
public:
StructuralMaterialTypeFilter(
	StructuralMaterialType structuralMaterialType
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.Structure StructuralMaterialType
The structural material type to match.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also