This method is called when a 3D Curve is being output.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- node
- Type: Autodesk.Revit.DB CurveNode
An output node that represents a Curve.
Return Value
Return RenderNodeAction.Proceed if you wish to receive tessellated geometry (line or polyline segments) for this curve, or otherwise return RenderNodeAction.Skip.Remarks
Note that this method is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.
The curve can be one of the geometric object that derive from the Curve class, e.g. Line, Arc, NurbeSpline, etc. To get to the specific properties of the particular class, the curve obtained from the input node first needs to be cast accordingly depending on the curve's actual type.