TypeId Property


The identifier of this subelement's type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public ElementId TypeId { get; }
Visual Basic
Public ReadOnly Property TypeId As ElementId
	Get
Visual C++
public:
property ElementId^ TypeId {
	ElementId^ get ();
}

Remarks

Some subelements cannot have type assigned, in which case this method returns invalid element id.

See Also