Calculates the intersection of the specified curve with this face and returns the intersection results.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curve
- Type: Autodesk.Revit.DB Curve
The specified curve to intersect with this face.
- results
- Type: Autodesk.Revit.DB IntersectionResultArray %
Provides more information about the intersection.
Return Value
- SetComparisonResult.Overlap - One or more intersections were encountered. The output argument has the results.
- SetComparisonResult.Subset - The curve is coincident with the surface.
- SetComparisonResult.Disjoint - There is no intersection found.
Remarks
The array of the intersection results contains one entry for each point where this face and the curve intersect. The following is the meaning of IntersectionResult's members:
- XYZPoint is the evaluated intersection point.
- UVPoint is the intersection parameters on the face.
- Parameter is the raw intersection parameter on the curve.
- EdgeObject is the edge if the intersection happens to be near an edge of the face.
- EdgeParameter is the parameter of the nearest point on the edge.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | The curve is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions InvalidOperationException | The intersection calculation fails. |