Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- outline
- Type: Autodesk.Revit.DB Outline
The Outline used to find elements with a bounding box that intersect it.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | outline is an empty Outline. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |