ModelPath Class


A path to a file stored on a disk or on a server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2012

Syntax

C#
public class ModelPath : IDisposable
Visual Basic
Public Class ModelPath _
	Implements IDisposable
Visual C++
public ref class ModelPath : IDisposable

Remarks

ModelPaths are paths to another file. They can refer to Revit models, or to any of Revit's external file references (DWG links, for example.) Paths can be relative or absolute, but they must include an extension indicating what kind of file it is. Relative paths are generally relative to the currently opened document. If the current document is workshared, paths will be treated as relative to the central model. To create a ModelPath, use the derived classes FilePath , ServerPath and CloudPath. The class ModelPathUtils contains utility functions for converting ModelPaths to and from strings.

Inheritance Hierarchy

See Also