IsValidObject Property


Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
	Get
Visual C++
public:
property bool IsValidObject {
	bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also