Returns the vectors describing the edge at the specified parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- parameter
- Type: System Double
The parameter to be evaluated.
Return Value
The transformation containing a tangent vector, derivative of tangent vector, and bi-normal vector.Remarks
The following is the meaning of the transformation members:
- Origin is the point on the edge (equivalent to Evaluate);
- BasisX is the tangent vector (the first derivative);
- BasisY is the second derivative;
- BasisZ is the bi-normal vector (tangent x normal).