Adds an external resource to the folder path by supplying the resource name and reference information.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- resourceName
- Type: System String
The unique short name of external resource.
- referenceInformation
- Type: System.Collections.Generic IDictionary String , String
The (String, String) map containing reference or lookup information that will be stored in Revit.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The resourceName is not a valid resource name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path + resourceName) should not exceeds 259. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |