GetFormula Method


Returns the parameter's expression in form of a string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public string GetFormula()
Visual Basic
Public Function GetFormula As String
Visual C++
public:
String^ GetFormula()

Return Value

The string representing the expression assigned to the parameter.

Remarks

Returns an empty string a case the parameter is not determined by a formula, or if the the expression cannot be converted to a string.

See Also