PreviewControl Class


Presents a preview control to browse the Revit model.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public class PreviewControl : UserControl, 
	IDisposable
Visual Basic
Public Class PreviewControl _
	Inherits UserControl _
	Implements IDisposable
Visual C++
public ref class PreviewControl : public UserControl, 
	IDisposable

Remarks

The dialog or form or window host this preview control must be modal. The view can be any graphical view but not a non-graphical view. And only one can be active. The view can be manipulated by embedded view cube and the visibility and graphical settings set on the view will be evident in the preview control.

Inheritance Hierarchy

See Also