Assets Property


Returns a set of all the Assets within Revit of special type.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)

Syntax

C#
[ObsoleteAttribute("This property is deprecated in Revit 2019. Use Application.GetAssets(AssetType) instead.")]
public AssetSet this[
	AssetType A_0
] { get; }
Visual Basic
<ObsoleteAttribute("This property is deprecated in Revit 2019. Use Application.GetAssets(AssetType) instead.")> _
Public ReadOnly Property Assets ( _
	A_0 As AssetType _
) As AssetSet
	Get
Visual C++
[ObsoleteAttribute(L"This property is deprecated in Revit 2019. Use Application.GetAssets(AssetType) instead.")]
public:
property AssetSet^ Assets[AssetType A_0] {
	AssetSet^ get (AssetType A_0);
}

Remarks

Each Asset stores the information for rendering etc.

See Also