Append shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShapeType. The data stored in the supplied ShapeBuilder object will be cleared.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ShapeBuilder
- Type: Autodesk.Revit.DB ShapeBuilder
The ShapeBuilder object that was used to build the shape to be appended.
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have teh correct appearance in Revit. This function will bypass extra geometry validation because the built geometry has already been validated by the ShapeBuilder. It is therefore slightly more efficient than the AppendShape() routine that accepts GeometryObjects directly as input.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |