Creates a new closed curve loop by thickening the input curve with respect to a given plane.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- pCurve
- Type: Autodesk.Revit.DB Curve
The input curve.
- thickness
- Type: System Double
The distance between the offset curves created on either side of the input curve.
- normal
- Type: Autodesk.Revit.DB XYZ
The normal vector to the plane used for thickening.
Return Value
The new curve loop.Remarks
The new loop will be created via offsets of the input curve (in the plane of the normal vector) with the endpoints connected with lines.The original curve will be at the center of the new loop.
Note that for input elliptical fragments and NurbSpline curves, any offsets will be created as HermiteSplines.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input thickness is too short for a curve. -or- The input pCurve points to a helical curve and is not supported for this operation. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | Throws if the input curve could not be thickened. |